icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.kjhyy.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

火红彩票网 www.308396.com-中福快三是哪里出的| www.5272.me-体育彩票站营业时间| www.285698.com-助赢彩票软件app| www.636049.com-500彩票ios-| www.762169.com-足彩滚球软件| www.865705.com-福利彩票加盟费| www.953443.com-彩神ix怎么玩赚钱| www.cp1518.com-快三线上平台| www.9868.cc-三杯体彩福彩| www.e45.me-湖北快三和值推荐| www.r98.biz-下载注册彩金36| www.020601.com-江苏福彩抉3一定牛| www.31242.com-时时彩定位胆算法| www.ys42.com-山东福利彩票兑奖| www.004029.com-中国福利彩票昨日| www.128745.com-河北福彩有几种玩法| www.213224.com-吉林快三分析软件| www.48477.com-足球竞彩网下载| www.9kr.com-四川福彩手机报下载| www.1620.xyz-体彩地方彩-| www.438222.cc-体彩排五预测论坛| www.609777.com-彩票开奖app| www.759931.com-广州天天溢彩| www.874436.com-彩票老谢大乐透预测| www.974888.cc-111cc彩票网站| www.6hh.cc-七星彩第2287| www.506.cn-台湾福星彩当期资料| www.23445.com-彩票一注一百倍| www.036771.com-福彩体彩缩水程序| www.146966.com-即乐彩福建体彩网| www.563787.com-福彩3d计算法| www.631598.com-江苏快彩快三| www.49940.com-彩神大发预测| www.770143.com-时时彩四星稳赚方法| www.7390.vip-哪个平台可以买竞彩| www.zz80.com-爱投彩票官网| www.0167.xyz-飞彩网能玩吗| www.028230.com-玩投彩是何用意| www.231672.com-快三二不同号| www.028663.com-浙快乐彩最新开奖| www.674342.com-彩票吉利七个数字| www.085208.com-红包彩票直播间| www.250398.com-有快三的中彩彩票| www.019468.com-体彩排列三字谜论坛| www.474889.com-网上说的彩票能信吗| www.875934.com-新版本约彩365| 彩票坊www.022m.cc| www.518801.com-发彩网是合法的吗| www.752377.com-中彩国际彩票学院| www.81709.com-吉林快三最近一百| www.088622.com-吉林快三走势图大全| www.3162.win-胜负彩怎么算中奖| www.369134.com-天空彩票与你同行| www.65625.com-双色球走势彩吧助手| www.505563.com-体彩飞鱼开奖结果| www.180576.com-天天中彩票app| www.272593.com-电脑彩报-| www.237640.cc-彩票站有北京快三么| www.53hh.com-福彩3d中奖查询器| www.836177.com-迪士尼彩乐园登录| www.913987.com-快三是全国彩票吗| www.975674.com-河南人上蔡县彩礼| www.cp199.com-湖北精彩十分开奖结| www.km31.com-足球竞彩网比分直播| www.q00.in-彩票天天彩选四| www.44ya.com-彩票中奖大奖视频| www.743.live-百乐彩色钢笔| www.2238.bid-彩票店搞笑标语| www.724777.cc-七乐彩基本走势| www.888804.cc-网易彩票电脑版首页| www.cp9033.com-专业购彩彩票平台| www.ve40.com-幸运彩网址-| www.91ra.com-网上购彩几时恢复| www.751707.com-彩票出号易学原理| www.826076.com-快三组合图片大全| www.948427.com-体育彩票公益事业| www.cai5066.com贵州快三开奖查询| www.31292.com-鄂尔多斯中彩票| www.eq50.com-快三秒奶茶店加盟| www.526913.com-竟彩稳胆-| www.104798.com-彩票中奖得主| www.969252.com-快三技巧吧-| www.003606.com-恒彩88测速-| www.14qf.com-彩票开发的行业前景| www.033668.com-小乐彩下载-| www.144038.com-竞彩盘口规律| www.273208.com-中国福彩发行原则| www.384656.com-超级福彩是什么意思| www.557534.com-皇室彩票是骗局吗| www.969883.com-为什么不关闭彩票| www.cp8389.com-彩票刮刮乐中奖绝招| www.29748.com-米兰快彩-| www.962106.com-聚宝快三大小计划| www.066060.com-福州私彩-| www.815832.com-手游彩下载-| www.903602.com-彩票中奖信息| www.982845.com-福彩3d正版折线图| www.wo3.cc-新浪彩票开奖公告| www.tg56.com-108休闲快三| www.cai5670.com内蒙快三开奘结果| www.321130.com-中彩网体育彩票排5| www.8309.org-福彩三d新吧第一版| www.37876.cc-天天中彩为什么被封| www.002398.cc-苏州彩票店生意转让| www.071254.com-腾讯彩票招聘| www.33486.com-彩神帝彩票-| www.131162.com-河南体彩排三| www.251705.com-旺彩超级大乐透软件| www.368455.com-彩铅日落风景画教程| www.466294.com-秒秒彩合法的吗| www.550948.com-合买中心彩票源码| www.619287.com-体彩卫视-| www.36696.com-澳门分分彩官网| www.12886.cc-全民彩票怎么买| www.13477.com-阳光彩票注册| www.435796.com-怀城体彩微信公众号| www.479761.com-足彩半场让球规则| www.598290.com-有谁买彩票中过大奖| www.698642.com-k彩彩民福地登陆| www.804300.com-网络体彩-| www.893267.com-免费彩票组合软件| www.973527.com-体彩大乐透有假吗| www.hw42.com-快三是国家开的吗| www.362296.com-万豪彩票手机助手| www.435468.com-都匀彩票中心在哪| www.502087.com-彩票平台制作教程| www.563825.com-万易彩票-| www.611655.com-77838巨龙彩票| www.667899.com-中国体彩排列五开奖| www.625357.com-彩票客服电话号多少| www.90ke.com-e彩在线登录| www.026574.com-伟德体彩app| www.144804.com-竞彩网页-| www.150709.com-福彩3d黑苍蝇彩报| www.265944.com-买快三有赚钱的吗| www.357951.com-九千万彩票大发快三| www.557864.com-凤翔彩票软件下载| www.619379.com-对福彩3d的解释| www.801236.com-手机彩票966| www.972241.com-买彩员-| www.zx23.com-东方亮彩怎么样| www.22631.cc-玩彩网靠不靠谱| www.642422.com-彩票6000万-| www.115908.com-买彩票几点开始| www.227233.com-分分快三输惨| www.329865.com-体彩贵州11选五| www.402265.com-哪个购彩软件好用吗| www.25rp.com-华彩电梯-| www.23278.cc-游戏新快三| www.859815.com-9彩app下载-| www.955954.com-足彩胜负彩开奖结果| www.bd8.cc-湖北省福彩快3| www.580724.com-福彩最大值走势图| www.31936.cc-上海福彩3d走勢圖| www.43335.com-旺彩双色球苹果老版| www.c98.win-陕西十一选五百宝彩| www.xi66.cc-优乐彩票手机版下载| www.4509.top-福利彩票推算| www.641.in-网上平台彩票网站| www.490072.com-福利彩票经验技巧| www.626611.com-彩名彩票app| www.719822.com-徐水彩票站-| www.78869.com-体彩中奖诀窍| www.031003.com-珍爱网男生引导彩票|